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Section 1 Installation of Scan2Run Workflow Module

1.1 Introduction
The Scan2Run Workflow Module enables the user to select a job and provide 
variable job data using a handheld barcode scanner connected to the printer.

The barcode scanner can be connected to printer through USB or RS232 serial connection.

For more information contact Videojet customer service or your local distributor. Alternatively refer 
to the VideojetConnect™ Workflow Portal for information.

1.2 Installing Workflow Module
The Software Download tool allows the user to install, uninstall and update Workflow Module.

To install the Workflow Module, follow the steps below:

1. Turn on the printer. The printer will start up and on completion, Home screen will be displayed. 
The printer will be in SHUTDOWN mode as shown in Figure 1-1.

Figure 1-1: Home Screen
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Installation of Scan2Run Workflow Module

2. Touch the Login button and set the role to Admin user level. Enter the required password 
(default = 3333) to login to the system (Figure 1-2).

3. Navigate to Tools > Software Download > Install Workflow Module(s) as shown in Figure 1-3.

4. Select the required drive from the drop down list.

5. Touch the Install button to start the installation procedure.

The installation of Scan2Run Workflow Module to the printer is complete. The printer will now 
restart.

Note: After the restart, the printer will display a maintenance alert that the installation of Scan2Run 
Workflow Module was successful.

Figure 1-3: Software Download

Figure 1-2: Login Screen
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Section 2 Scan2Run Setup

2.1 Spare Parts
The parts below are required for each application and are ordered separately.

2.2 RS232/USB Setup Procedure

For RS232 Setup:
1. Navigate to Tools > Scan2Run and select the checkbox to enable the Scan2Run Workflow 

Module as shown in the Figure 2-1.

Note: Ensure that the barcode scanner is connected to the printer through RS232 connector.

2. Set the scanner type to Serial for RS232 connection.

Part Number Part Description Quantity

RS232 Kit

MS0965-17 Barcode Scanner Kit 1

MS1371 Cable Adapter 1

611197 RS232 Cabinet Connector 1

USB Kit

MS0965-USB Barcode Scanner Kit 1

Table 2-1: Parts List

Figure 2-1: Scan2Run Screen - Serial
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3. Navigate to Tools > Communications > COM5 and set the protocol to Scan2Run from the drop 
down list as shown in the Figure 2-2.

Note: Make sure that the RS232 connection settings are correct.

4. Navigate to Tools > Scan2Run > Settings and confirm the connection is set to COM5.

For USB Setup:
1. Navigate to Tools > Scan2Run and touch the checkbox to enable the Scan2Run Workflow 

Module as shown in the Figure 2-3.

Note: Ensure that the barcode scanner is connected to the printer through USB connector.

2. Set the scanner type to USB as shown in the Figure 2-3.

Figure 2-2: Communications Screen

Figure 2-3: Scan2Run Screen - USB
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Scan2Run Setup

2.3 Markers Setup
Navigate to Tools > Scan2Run > Markers to set the leading characters of barcode as shown in the 
Figure 2-4. 
Note: The leading characters are the identifiers of the data found in the barcode. If these are all 

empty, the Scan2Run will read the barcode and will use the data read as the name of the job 
to select from memory.

Note: Letters or symbols can be used in the marker fields. These characters will be read and 
removed so they will not print in the output.

Note: The job and the data markers allows the user to use same scanner for both job selection 
and user field data update purposes.

The Markers screen provides the access to the following options as shown in Table 2-2.

Figure 2-4: Scan2Run Screen - Markers

Option Description

Job Marker The job marker is a unique identifier which can be included at the beginning 
of the each string of the scanned barcode data. The identifier enables the 
printer to detect the data as a job name from printer’s memory. The printer 
will perform job selection functions if the scanned barcode data is a job 
name.

Data Marker 1 The data marker is a unique identifier which can be included at the 
beginning of the each string of the scanned barcode data. The identifier 
enables the printer to detect the data as a user field data. The printer will 
dynamically update the field(s) of the current job if the scanned barcode data 
is a user field data.
For example, the symbol “@” will identify the data from the barcode scanner 
at the beginning of data read. This data will be placed into the user field.
Note: Data markers correlate to user prompted fields in the order in which 
the prompted fields were added to the message.

Data Marker 2

Data Marker 3

Data Marker 4

Table 2-2:  Markers
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2.4 Test Setup

2.4.1 Create a New Job for Testing
1. Touch the Jobs button and the job list screen opens as shown in the Figure 2-5.

2. Touch the +New button to create a new job. The Job Settings screen opens as shown in 
Figure 2-6.

 

Figure 2-5: Job List Screen

Figure 2-6: Information Screen
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Scan2Run Setup

3. Touch the Job Name text box to enter the job name for the new job. The Job Name screen 
opens.

Note: The user can also provide the job description for the new job.

4. Enter VIDEOJET using utility keypad and touch the Accept button.

5. Touch the Done button on the Job Settings screen.

Note: The user can also change the setup, parameters and instructions details.

6. Job Editor screen opens as shown in Figure 2-7. 
 

7. Touch the + button and select text as shown in Figure 2-8. Touch the OK button.

Figure 2-7: Job Editor Screen

Figure 2-8: Add Field Options
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8. Set the Text type to User Prompted as shown in Figure 2-9 and save the field.

9. Create another text field, perform Step 7 to Step 8 and Job Editor screen is as shown in 
Figure 2-10.

10.Touch the Save button to save the job.

11.Now the job is available in the job list. Select the job and click on the Run Job button.

Figure 2-9: Field Settings Screen

Figure 2-10: Job Editor Screen
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Scan2Run Setup

12.Click on the Load Job button to load the job. The Home screen opens as shown in 
Figure 2-11.

13.Perform Step 1 to Step 12 to create a new job called MESSAGE1.

2.4.2 Barcode Scanner/Data Source Programming
The barcode data should have the following prefix and suffix so that it can be detected by the 
barcode scanner.

• Start of Text Character STX or 00x02 hexadecimal
• End of Text character ETX or 00x03 hexadecimal
• Characters sent must be in ASCII characters

For example, the barcode data: [02]!VIDEOJET[03]

[02] = STX Start of Text Character

[03] = ETX End of Text Character

This example will select the job “VIDEOJET” from the printer’s memory of Job list. 

Note: The data is case sensitive so if the Job is stored as “videojet” this will not be recalled from 
memory, the name must be “VIDEOJET”.

Figure 2-11: Home Screen
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Scan2Run Setup

2.4.3 Test Program

2.4.3.1 Example 1
The barcode data: [02]!VIDEOJET[03]

This example will select the job “VIDEOJET” from the printer’s memory of job list. 

Note: This data is case sensitive so if the job is stored as “videojet” this will not be recalled from 
memory. The name must be “VIDEOJET”.

Using ESI Tester program to send the RS-232 control characters and ASCII text to printer.

Figure 2-12: ESI Tester - Example 1
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Scan2Run Setup

2.4.3.2 Example 2
The barcode data: [02]@1234567890[03]

This example will populate the user field 1 (first entered job) with the characters of 
“1234567890”.

Figure 2-13: ESI Tester - Example 2
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2.4.4 Testing Setup
Using the ESI Tester program or a barcode scanner, the test screen will allow the operator to see 
what the external device is sending into the printer.

Data sent from ESI Tester or Barcode Scanner: [02]VIDEOJET[03]

1. Confirm the Scanned Data shows “VIDEOJET”.

2. The Detected Data Type displays “Unknown” because the data does not contain a known 
marker or does not match a name of a job in the printer’s memory.

Figure 2-14: Test Screen 1

Figure 2-15: Barcode - Test 1
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Data sent from ESI Tester or Barcode Scanner: [02]@1234567890[03]

1. Confirm the Scanned Data shows“@1234567890”.

2. The Detected Data Type displays “User Prompted Data” because the scanned data is leading 
with a “@” which is setup as one of the printer user field markers.

3. The printer can recognize the data as user prompted data and places this data into the 
specified location within the job.

Figure 2-16: Test Screen 2

Figure 2-17: Barcode - Test 2
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Scan2Run Setup

Data sent from ESI Tester or Barcode Scanner: [02]!MESSAGE1[03]

1. Confirm the Scanned Data shows “!MESSAGE1”.

2. The Detected Data Type text displays “Job Data” because the scanned data is leading with a 
“!” which is setup as the job marker.

3. The printer can recognize the data as job name and will call the job MESSAGE1 from the 
printer’s memory.

Note: If there are no markers setup the printer will assume that each inbound data string 
represents a job name.

Figure 2-18: Test Screen 3

Figure 2-19: Barcode - Test 3
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Section 3 Programming the Scanner

3.1 How to Program Barcode Scanner to Send STX Prefix and ETX Suffix
Do the following tasks to scan the barcode using RS232/USB barcode scanner:

Note: 1) For RS232 barcode scanner, follow Step 1 to Step 8.

2) For USB barcode scanner, follow Step 1 to Step 10.

1. Enter the Programming mode by scanning Enter/Exit Programming mode barcode.

2. Scan Set Prefix barcode.

3. Scan “0” and “2” barcodes. (Hex for STX).
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4. Save the prefix.

5. Enter the Programming mode by scanning Enter/Exit Programming mode barcode.
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Programming the Scanner

6. Scan Set Suffix barcode.

7. Scan “0” and “3” barcodes. (Hex for ETX).
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8. Save the suffix.

For USB Scanners Only:
9. Enable sending control characters.
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10.Test USB scanner output as follows:

a. Open Notepad++.

b. Navigate to View > Show Symbol > Show All Characters.
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c. Create a new document, place the mouse cursor in the document and scan the following 
barcode.

d. The output is displayed as shown in the Figure 3-1.

e. If the output is not as shown in the Figure 3-1, repeat Step 1 to Step 9.

3.2 How to Create a Barcode Using Web Site
The following program is a free program that can be used from the internet. This can be used to 
create some barcodes to test the Scan2Run features.

Web Site: https://www.free-barcode-generator.net/code-128/

Figure 3-1: Output Screen
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Do the following tasks to create a barcode:

1. Enter the text to be inserted into barcode.

2. Set the Convert Substrings to Yes.

3. Click on Generate button.

4. Select JPG, this will create the barcode as an image.

Note: To read the barcode effectively, increase the size of the barcode.

Now the image can be used to read from screen or paste into a document.
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3.3 Additional Barcodes

Figure 3-2: 128 Barcode

Figure 3-3: UPC-A Barcode
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Figure 3-4: Code 3 of 9 Barcode

Figure 3-5: Interleaved 2 of 5 Barcode
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